The Robservatory

Robservations on everything…

 

Install macOS 10.15 Catalina in a Fusion virtual machine

While I have older hardware (a 2013 MacBook Pro) that I use for testing macOS betas—it’s now running Catalina—it’s often handy to have the latest macOS beta running in VMware Fusion on my iMac. With past OS releases, this has been a relatively easy process. With Catalina, however, attempting the install results in a black screen.

Thankfully, some enterprising Fusion users (Bogdam and intel008) have figured out a workaround. I tried it, and while it did work for me, I had to change the instructions just a bit (read on for the details).

I’m not going to replicate the entire blog post here, as it’s quite involved (and includes lots of helpful screenshots), but the short version is that it requires setting up a new VM (upgrading will not work!) as a macOS 10.14 guest, customizing the settings to change it to a Windows 10 x64 (yes, really) guest, launching the VM setup tool by dropping the Catalina installer app on it, interacting with the Windows 10 boot controller a couple times, then finally changing the VM back to a Mac guest OS.

That all sounds great, so I set to work, and all was progressing well…until I reached the part that reads…

Select “Boot normally” and press Enter.

This should then give you the normal boot progress screen:

But for me, it didn’t provide the boot progress screen. Instead, I saw a few boot failed messages—it looked like it couldn’t find a boot volume—and I wound up back at the same screen.

After a few cycles of this, and not sure what to do about it, I tried something on a lark, and it worked: I shut down the VM, then opened its settings, went to General, and changed the OS type back to macOS 10.14 from Windows 10 x64.

When I then restarted the VM, macOS booted to the initial setup screen (select a region, etc.), and everything worked.

As it turns out, it seems that my installer had run all the way through before getting to the Windows controller boot screen for the first time, because what I did as a fix is listed as the next steps after the installer finishes, which the instructions describe as hapening after the first visit to the Windows controller boot screen. I have no idea why mine worked in a different manner.

One thing that may not be obvious from the instructions is how to actually get the macOS Catalina installer app you need to proceed. To do that, you need to install the Catalina profile from Apple’s developer download page (login required). Then open System Preferences > Update, and let the installer download. When it’s fully downloaded, quit System Preferences, and you’ll find “Install macOS 10.15 Beta.app” in your Applications folder.

If you don’t want to install the profile on your actual Mac, you can follow the above steps in an existing virtual machine, then copy the installer to your actual Mac via drag-from-VM or via file sharing. You then drag this image into the new VM’s setup screen to start the process.

Final note: I had to run the Install VMware Tools command twice. Run it once and then approve all the security requests and allow the extension, reboot, then run the Tools installer again, and it should work.

Great thanks to those who figured this out—having a virtualized beta to test with is incredibly convenient.

1 Comment

Add a Comment
  1. Thanks for this post! I saw this after I’d muddled my way through my first installation of the initial beta.

    Not sure what the reason (interesting that the first one was called “10.15 beta”, not “Catalina beta” like the current one), but the second beta did require a complete fresh installation that didn’t seem to work in VM. I deleted the initial VM when I couldn’t figure out how to update it. I did follow the PlanetVM.net instructions and it took only one attempt, a handful fewer than the first beta on my own.

Leave a Reply to Joel Cancel reply

The Robservatory © 2018 • Privacy Policy Built from the Frontier theme